OpenSSL multi-block功能拒绝服务漏洞(CVE-2015-0290)

  • A+
所属分类:linux安全
摘要

支持AES NI的64位x86平台上,OpenSSL 1.0.2版本存在拒绝服务漏洞,此漏洞可导致指针损坏及程序崩溃。此漏洞位于s3_pkt.c中ssl3_w

发布日期:2015-03-19
更新日期:2015-03-20

受影响系统:
OpenSSL Project OpenSSL < 1.0.2a
描述:
CVE(CAN) ID: CVE-2015-0290

 OpenSSL是一种开放源码的SSL实现,用来实现网络通信的高强度加密,现在被广泛地用于各种网络应用程序中。

 支持AES NI的64位x86平台上,OpenSSL 1.0.2版本存在拒绝服务漏洞,此漏洞可导致指针损坏及程序崩溃。此漏洞位于s3_pkt.c中ssl3_write_bytes函数的multi-block功能实现内,原因是由于没有正确处理某些非块I/O情况。

<*来源:Daniel Danner
 
  链接:https://openssl.org/news/secadv_20150319.txt
 *>

建议:
厂商补丁:

OpenSSL Project
 ---------------
 OpenSSL Project已经为此发布了一个安全公告(secadv_20150319)以及相应补丁:
secadv_20150319:OpenSSL 1.0.2 ClientHello sigalgs DoS (CVE-2015-0291)
链接:https://openssl.org/news/secadv_20150319.txt

补丁下载:https://git.openssl.org/?p=openssl.git;a=commit;h=76343947ada960b6269090638f5391068daee88d

通过OpenSSL提供FTP+SSL/TLS认证功能,并实现安全数据传输 http:///Linux/2013-05/84986.htm

利用OpenSSL签署多域名证书 http:///Linux/2014-10/108222.htm

weinxin
欢迎加入中国站长博客之家
本站的所有资源都会上传分享到博客之家,希望大家互相学习交流进步。

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: